We are continuing to process work orders to correct the issue causing them not to appear in the available work list. As we are now working through older work orders we believe the vast majority of work that is available has been processed. We will continue to work through all work orders and mark the incident fully resolved when finished, but we believe things to be operational for our providers.
Posted Mar 15, 2025 - 17:56 CDT
Monitoring
We have implemented a fix and we are seeing work populate in the available work listing. We have prioritized more recently created work and are working through a backlog of more older work orders.
Posted Mar 15, 2025 - 17:34 CDT
Identified
We believe we have identified the issue causing this and preparing a fix.
Posted Mar 15, 2025 - 16:57 CDT
Investigating
We are actively investigating an issue causing providers to see very little or no available jobs in the available work listing.