Field Nation platform is not accessible due to an outage of our cloud service provider

Incident Report for Field Nation

Resolved

The issues have fully resolved and the Field Nation platform is fully available.
Posted Oct 20, 2025 - 06:09 CDT

Monitoring

We are recovering from a service outage caused by a widespread disruption at our cloud provider, Amazon Web Services (AWS). This issue affected Field Nation as well as many other online services.

We apologize for the delay in this update. Our status page service was also impacted by the AWS outage, which temporarily prevented us from posting.

AWS has identified the root cause as a DNS issue and is seeing recovery. We are also seeing the Field Nation platform stabilize and services become accessible. Our team is continuing to monitor the situation closely to ensure a full recovery.

Thank you for your patience.

AWS updates are available here: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 05:49 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 20, 2025 - 05:42 CDT
This incident affected: Web App, Mobile App, API, and Out of the box Integration connectors.